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Τεχνολογίες Διαδικτύου - Εργαστήριο 1ο  

 

1.  Δημιουργία μιας απλής σελίδας HTML 

Χρειάζεστε έναν κειμενογράφο. Προτείνεται η εγκατάσταση του notepad++ 

(https://notepad-plus-plus.org/downloads/ ).  

Στον δίσκο σας δημιουργήστε ένα φάκελο με όνομα HTML.  

Ανοίξτε το Notepad++ (ή notepad) ακολουθώντας τη διαδρομή (Start → All Programs  

→ Notepad++) και  πληκτρολογήστε το ακόλουθο κείμενο: 

<!DOCTYPE html> 

<html> 

<head> 

<title>Παράδειγμα σελίδας HTML</title> 

</head>  

<body> 

<h3> Μαθαίνοντας την HTML </h3> 

<p>Αυτή είναι μια απλή πρόταση.</p> 

</body> 

</html> 

Επιλέξτε File → Save και αποθηκεύστε το αρχείο με  όνομα  ton-arithmo-mitroou-

sas.html στoν προσωπικό σας κατάλογο. Κλείστε το Notepad++, πηγαίνετε προσωπικό 

σας κατάλογο στο φάκελο HTML και ανοίξτε τη σελίδα που δημιουργήσατε κάνοντας 

διπλό κλικ στο εικονίδιό της. 

Επιλέξτε View -> Source  για να δείτε τον κώδικα της σελίδας HTML. Θα εμφανιστεί 

ένα παράθυρο που περιλαμβάνει τον κώδικα που πληκτρολογήσατε. (δεξί κλικ σε 

λευκή περιοχή της σελίδας, όπως στην παρακάτω εικόνα) 

 

Για να τροποποιήσετε τον κώδικα μιας ιστοσελίδας, που εμφανίζεται μέσω του Firefox, 

θα πρέπει να την ανοίξετε μέσω ενός editor (π.χ. Notepad). 

Παρατήρηση: 

Μπορείτε να τροποποιήσετε τον κώδικα της ιστοσελίδας σας στο notepad++, να 

αποθηκεύσετε τις αλλαγές σας και να δείτε τα αποτελέσματα, επιλέγοντας ανανέωση 

(refresh ή ctrl+R) από το μενού επιλογών του φυλλομετρητή. Δεν χρειάζεται, δηλαδή, 

να κλείνετε και να ανοίγετε το παράθυρο του φυλλομετρητή.  

https://notepad-plus-plus.org/downloads/
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2.  Ετικέτα <meta> metadata 

Στο head της σελίδας HTML (πριν από την ετικέτα </head>) προσθέστε το 

παρακάτω. 

<meta charset="iso-8859-1"> 

Επιλέξτε File → Save και αποθηκεύστε το αρχείο. Μεταβείτε στο φυλλομετρητή σας 

και επιλέξτε ανανέωση (refresh) από το μενού επιλογών του φυλλομετρητή. Βλέπετε 

το περιεχόμενο της ιστοσελίδα σας; Μπορείτε να διαβάσετε ελληνικό κείμενο; 

Αλλάξτε την προηγούμενη ετικέτα ως εξής:   

<meta charset="utf-8"> 

Επιλέξτε File → Save και αποθηκεύστε το αρχείο. Μεταβείτε στο φυλλομετρητή σας 

και επιλέξτε ανανέωση (refresh) από το μενού επιλογών του φυλλομετρητή. Βλέπετε 

το περιεχόμενο της ιστοσελίδα σας; Μήπως τώρα μπορείτε να διαβάσετε ελληνικό 

κείμενο; 

Στο head της σελίδας HTML (πριν από την ετικέτα </head>) προσθέστε 

<meta http-equiv="refresh" content="5;url= http://www.cs.unipi.gr/"> 

Τί κάνει αυτή η ετικέτα; Τί είναι το ‘client pull’; 

Αποθηκεύσετε τις αλλαγές σας και να δείτε τα αποτελέσματα στο φυλλομετρητή. Στη 

συνέχεια αντικαταστήστε το  5 στην ανωτέρω ετικέτα με το 500. 

3. Σχόλια 

Περικλείστε την προηγούμενη ετικέτα meta με τα σύμβολα <!-- και -->, όπως 

φαίνεται παρακάτω.   

<!--    <meta http-equiv="refresh" content="5;url= http://www.cs.unipi.gr/">       --> 

Αποθηκεύσετε τις αλλαγές σας και να δείτε τα αποτελέσματα στο φυλλομετρητή. 

Πραγματοποιείται ανακατεύθυνση στην ιστοσελίδα σας; Γιατί; Μεταβήκατε στη 

σελίδα του τμήματος Πληροφορικής; Για να μεταβείτε στη νέα σελίδα κάνατε κάποιο 

κλικ στη δική σας σελίδα;  

4. Επικεφαλίδες 

Οι επικεφαλίδες ορίζονται με <hn> ετικέτες όπου n το μέγεθος της επικεφαλίδας. Η 

επικεφαλίδα <h1>Μία επικεφαλίδα</h1> θα παρουσιαστεί μεγαλύτερη από την <h2> 

Μία επικεφαλίδα </h2> κ.ο.κ. 

Παρατηρήστε ότι στον κώδικα της σελίδας HTML, που εμφανίζεται στο παράθυρο της 

εφαρμογής Notepad++, υπάρχει μια επικεφαλίδα τύπου h3 (<h3> Μαθαίνοντας την 

HTML </h3>). Ακριβώς από κάτω, προσθέστε τη γραμμή: 

<h4>Επικεφαλίδα HTML</h4> 

Επιλέξτε File->Save και στο παράθυρο του φυλλομετρητή, που παρουσιάζει τη σελίδα 

ton-arithmo-mitroou-sas.html επιλέξτε “Refresh” για να εμφανιστούν τα 

αποτελέσματα των αλλαγών σας. 

Τροποποιήστε πάλι το αρχείο αντικαθιστώντας την ετικέτα h3 με την h5 και την h4 με 

την h6. Αποθηκεύστε το αρχείο και στο φυλλομετρητή επιλέξτε “Refresh” για να δείτε 

τα αποτελέσματα των αλλαγών σας. 

http://www.cs.unipi.gr/
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Επαναλάβετε το ίδιο αντικαθιστώντας το h5 με h1 και το h6 με h2.  

5. Μορφή κειμένου  

Στη συνέχεια ανοίξτε πάλι το Notepad++, για να προσθέσετε και άλλο κείμενο στη 

σελίδα. Πριν από την τελική ετικέτα </body> προσθέστε τον ακόλουθο κώδικα: 

<strong>Κείμενο με έντονα γράμματα, </strong> 

<em>κείμενο με πλάγια γράμματα. </em> 

<ins>εισαγωγή κειμένου</ins> ή/και <del>διαγραφή κειμένου</del>. 

Αποθηκεύστε τις αλλαγές και επιλέξτε “Refresh” στο φυλλομετρητή για να τις δείτε. 

6. Μορφοποίηση 

Για να αλλάξουμε το στυλ και τον τρόπο εμφάνισης των γραμμάτων χρησιμοποιούμε 

το χαρακτηριστικό style που συνοδεύεται από ζευγάρια: ιδιότητα: τιμή;  

Για να αλλάξετε το χρώμα του κειμένου “Αυτή είναι μια απλή πρόταση” σε κόκκινο 

γράψτε: 

<p style="color: #ff0000;">Αυτή είναι μια απλή πρόταση</p> 

Αποθηκεύστε τις αλλαγές και επιλέξτε “Refresh” στο φυλλομετρητή για να τις δείτε. 

Στη συνέχεια αλλάξτε το χρώμα, το μέγεθος και τον τύπο των γραμμάτων του κειμένου 

“ κείμενο με πλάγια γράμματα ” ως εξής: 

<em style="color:blue; font-family:courier; font-size:300%;"> κείμενο με πλάγια 

γράμματα </em>  

Αλλάξτε και δώστε στην ιδιότητα font-size την τιμή 50px. Τί αλλαγές έγιναν;  

 

7. Αλλαγή γραμμής 

Για να αναγκάσουμε τον web browser να αλλάξει γραμμή χρησιμοποιούμε την ετικέτα 

<br>. Η συγκεκριμένη ετικέτα δε χρειάζεται συνοδευτικό </br>. Συνεπώς για να 

δημιουργήσουμε κείμενο που εμφανίζεται σε 2 γραμμές, μπορούμε να έχουμε κάτι σαν 

το παρακάτω: 

First line<br>Second line (μην το προσθέσετε στον κώδικά σας) 

Στον κώδικα του αρχείου “ ton-arithmo-mitroou-sas.html” προσθέστε αλλαγή 

γραμμής πριν τις ετικέτες <strong>, <em> και <ins>. 

Αποθηκεύστε και ελέγξτε τα αποτελέσματα των αλλαγών σας.  

8. Δημιουργία νέας Παραγράφου 

Για τη δημιουργία παραγράφου χρησιμοποιείται η ετικέτα <p>. Στον κώδικα της 

σελίδας HTML που φτιάξατε μέχρι τώρα προσθέστε πριν από το τέλος του body 

(Δηλαδή, πριν από την ετικέτα </body>) τις ακόλουθες σειρές: 

<p> Αυτή είναι μία παράγραφος που περιέχει δύο προτάσεις. Παρατηρήστε το 

περιθώριο που διαχωρίζει την παράγραφο από το υπόλοιπο κείμενο. </p>  

Αποθηκεύστε και ελέγξτε τα αποτελέσματα των αλλαγών σας.  

Σημείωση: Παρατηρήστε ότι η ετικέτα <br> απλώς αλλάζει γραμμή, ενώ η ετικέτα 

<p> αφήνει κενό από την προηγούμενη γραμμή.   
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9. Αλλαγή στοίχισης κειμένου 

Για να αλλάξουμε την στοίχιση (alignment) ενός κειμένου μπορούμε να αλλάξουμε της 

ιδιότητα text-align στο χαρακτηριστικό style στην ετικέτα <p>, με τιμές  ‘left’,  ‘right’ 

ή ‘center’, οι οποίες  μας δίνουν στοίχιση στα αριστερά, δεξιά ή στο κέντρο αντίστοιχα.  

Μέσα στην ετικέτα p που προσθέσατε προηγουμένως συμπληρώστε: 

<p style="text-align:center;"> 

Αποθηκεύστε το αρχείο και ελέγξτε τα αποτελέσματά σας. 

Ένας άλλος τρόπος για να αλλάξετε τη στοίχιση του κειμένου είναι με τη χρήση της 

ετικέτας <div></div> στην οποία μπορείτε πάλι να ορίσετε την ιδιότητα text-align στο 

χαρακτηριστικό style που θέλετε.  

Αντιγράψτε το τελευταίο στοιχείο παραγράφου και αντικαταστήστε την ετικέτα της 

παραγράφου με την div.   

<div style="text-align:center;"> Αυτή είναι μία παράγραφος που περιέχει δύο 

προτάσεις. Παρατηρήστε το περιθώριο που διαχωρίζει την παράγραφο από το 

υπόλοιπο κείμενο. </div>   

Αποθηκεύστε τις αλλαγές και ελέγξτε τα αποτελέσματά σας.  

10. Αλλαγή στοιχείων για όλη τη σελίδα 

Οι παράμετροι που δέχεται η ετικέτα <body> επηρεάζουν την παρουσίαση όλης της 

σελίδας. Τροποποιείστε την ετικέτα  <body> της σελίδας σας, όπως φαίνεται παρακάτω 

και παρατηρήστε τις αλλαγές. 

<body style="background-color:silver; color:black; margin: 100px 150px 100px 

80px;"> 

Τι χρώμα έχει το κείμενο; Τι χρώμα έχει η οθόνη του φυλλομετρητή ; Υπάρχουν 

περιθώρια γύρω από το κείμενο; Παρατηρείστε ότι η ιδιότητα margin δέχεται 4 τιμές, 

οι οποίες αντιπροσωπεύουν τις 4 πλευρές (επάνω, δεξιά, κάτω, αριστερά)  

11. Δημιουργία Λίστας 

Στην HTML μπορούμε να δημιουργήσουμε αριθμημένες λίστες με την χρήση της 

ετικέτας <ol> (Ordered List). Μπορούμε, επίσης, να δημιουργήσουμε μη αριθμημένες 

λίστες με τη χρήση της ετικέτας <ul>  (Un-ordered List). 

Κάθε στοιχείο της λίστας αυτής εσωκλείεται σε μία ετικέτα <li> (List Item).  

• Στη σελίδα HTML που δημιουργήσατε προσθέστε το παρακάτω, πριν την τελική 

ετικέτα </body>: 

<br><br><br><br>.  

Πόσες κενές γραμμές προσθέσατε;  

•  Προσθέστε τον παρακάτω κώδικα μη αριθμημένης λίστας: 

 

<ul> 

<li>πρώτο στοιχείο λίστας</li> 

<li>δεύτερο στοιχείο λίστας</li> 

<li>τρίτο στοιχείο λίστας</li> 

</ul> 
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Αποθηκεύστε τo αρχείο  και επιλέξτε “Refresh” στο φυλλομετρητή για να δείτε τις 

αλλαγές σας. Τί θα πρέπει να κάνετε για να εμφανιστούν σωστά τα Ελληνικά; 

• Χρησιμοποιήστε το: style="list-style-type:square" ώστε να αλλάξετε το σύμβολο 

της σε τετράγωνο 

• Στη συνέχεια προσθέστε τον παρακάτω κώδικα αριθμημένης λίστας 

 

<ol> 

<li> πρώτο στοιχείο </li> 

<li> δεύτερο στοιχείο </li> 

<li> τρίτο στοιχείο </li> 

<li>τέταρτο στοιχείο</li> 

</ol> 

Αποθηκεύστε το αρχείο και επιλέξτε “Refresh” στο φυλλομετρητή για να δείτε τις 

αλλαγές σας. 

Ένα στοιχείο της λίστας (List Item) μπορεί να περιέχει και αυτό με τη σειρά του μια 

νέα λίστα. Δημιουργήστε μία αριθμημένη λίστα μέσα στο τρίτο στοιχείο της 

αριθμημένης λίστας που φτιάξατε παραπάνω.  Για να γίνει αυτό αλλάξτε τη γραμμή 

<li> τρίτο στοιχείο </li>  σε: 

 

<li> τρίτο στοιχείο 

 <ol> 

<li> στοιχείο 1</li> 

<li> στοιχείο 2</li> 

</ol> 

</li> 

Το χαρακτηριστικό type ορίζει το είδος της αρίθμησης στην ol λίστα αντίστοιχα. Ενώ 

το χαρακτηριστικό start ορίζει το σημείο έναρξης της αρίθμησης της λίστας και το 

reversed ορίζει την αντιστροφή.     

Δοκιμάστε τις παρακάτω παραλλαγές στις λίστες που δημιουργήσατε: 

<ol type= "a"> 

<ol type= "A" start="3"> 

<ol type="i" start="100"> 

<ol type="1" start="100" reversed >  

(το χαρακτηριστικό reversed δεν υποστηρίζεται από τον ΙΕ ) 

12. Εισαγωγή Χωρίσματος 

Η ετικέτα <hr> (Horizontal Rule) μας δίνει τη δυνατότητα να χωρίσουμε δύο μέρη του 

κειμένου με μια οριζόντια γραμμή. Η ετικέτα αυτή, όπως και η <br> δε χρειάζεται 

ετικέτα </hr>. 

• Κάτω από την πρώτη (μη αριθμημένη) λίστα που δημιουργήσατε, εισάγετε μια 

οριζόντια γραμμή, προσθέτοντας την ετικέτα <hr> 

Αφού ελέγξετε τα αποτελέσματα των αλλαγών σας, χρησιμοποιήστε τις ιδιότητες  

height:4px; και width:50%; για να αλλάξετε στοίχιση και μέγεθος στη γραμμή. 

Δοκιμάστε τα ακόλουθα: 

<hr style="height:4px;width:50%;"> και  

<hr style="text-align: right;height:4px;width:500;"> 
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Τί παρατηρείτε; Για την ιδιότητα text-align ισχύουν τα παρακάτω:  

Σύνταξη για IE και Opera: <hr style="text-align: right; margin-left: auto;"> 

Σύνταξη για Firefox, Chrome, και Safari: <hr style="margin-right:0"> 

13. Εισαγωγή βίντεο  

Η χρήση της ετικέτας <video> δεν απαιτεί τη διαχείριση κανενός είδους βοηθητικής 

εφαρμογής για την αναπαραγωγή πολυμεσικών δεδομένων. Αποτελεί νέο στοιχείο της 

HTML5. Η ετικέτα <source> χρησιμοποιείται σε συνδυασμό με την ετικέτα <video>, 

ώστε να οριστούν πολλαπλές πηγές δεδομένων και ο φυλλομετρητής να αποφασίσει 

ποια μορφή είναι κατάλληλη γι’ αυτόν.   

• Από την ιστοσελίδα του μαθήματος (https://gunet2.cs.unipi.gr) βρείτε το αρχείο 

με τίτλο “csunipi.mp4” και αποθηκεύστε τοπικά στο ίδιο κατάλογο/φάκελο με 

το αρχείο ton-arithmo-mitroou-sas.html 

• Στο τέλος του εγγράφου, πριν την ετικέτα </body> προσθέστε τον παρακάτω 

κώδικα.  

<video width="320" height="240" > 

   <source src="csunipi.mp4" type="video/mp4"> 

     Εναλλακτικό κείμενο για την περίπτωση όπου ο φυλλομετρητής δεν 

υποστηρίζει αυτή τη λειτουργία. 

</video> 

• Αποθηκεύστε και αφού ελέγξετε τα αποτελέσματα των αλλαγών σας, 

χρησιμοποιήστε τις ιδιότητες  autoplay=’yes’ controls=’yes’ στην ετικέτα 

video. Τι κάνουν;  
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14. Εργασία προς παράδοση 

Με τη βοήθεια ενός απλού κειμενογράφου (notepad, notepad++, editplus) να γραφτεί 

μια σελίδα HTML που να περιγράφει κάποια βιογραφικά σας στοιχεία όπως το 

ονοματεπώνυμό σας, τον Αριθμό Μητρώου, το Τμήμα που ανήκετε, την πόλη που 

γεννηθήκατε  κτλ. 

Να μορφοποιήσετε τη σελίδα έτσι ώστε να βελτιωθεί η εμφάνισή της και κατ` 

ελάχιστο:  

- να περιέχει μια επικεφαλίδα πρώτου μεγέθους και μια επικεφαλίδα δευτέρου 

μεγέθους 

- να περιέχει μια παράγραφο η οποία περιλαμβάνει σημαντικές λέξεις με έντονα 

γράμματα, λέξεις οι οποίες χρειάζονται έμφαση, διαγραμμένες φράσεις, καθώς 

και φράσεις οι οποίες έχουν εισαχθεί πρόσφατα   

- η πρώτη γραμμή της παραγράφου θα παρουσιάζει εσοχή προς τα δεξιά κατά 2 

κενούς χαρακτήρες.   

- να περιέχει μια παράγραφο με χρώμα υπόβαθρου της επιλογής σας (όχι μαύρο), 

μεγέθους γραμματοσειράς 25 και στοίχιση κειμένου δεξιά 

- μεταξύ των δυο παραγράφων παρεμβάλλεται μια οριζόντια γραμμή η οποία 

είναι χρώματος της επιλογής σας και καταλαμβάνει το 50% της οθόνης του 

φυλλομετρητή    

- μετά τις παραγράφους και αφού έχουν εισαχθεί πέντε αλλαγές γραμμής 

εμφανίζει μια λίστα με ρωμαϊκή φθίνουσα αρίθμηση, η οποία ξεκινά από το 

150. Η λίστα θα πρέπει να βρίσκεται εντός των περιθωρίων της σελίδας. 

(χρήσιμες ιδιότητες: margin, padding, border)  

- παρουσιάζει σε ολόκληρη την ιστοσελίδα περιθώρια πάχους 5px, ενιαίας 

γραμμής και χρώματος της επιλογής σας. (χρήσιμες ιδιότητες: margin, padding, 

border) 

- διασφαλίζει ότι οποιοδήποτε ελληνικό κείμενο εμφανίζεται ορθά στο 

φυλλομετρητή. 

- στη μπάρα διεύθυνσης του φυλλομετρητή θα εμφανίζει, μαζί με τη διέυθυνση 

της, ένα εικονίδιο δική σας επιλογής (favicon). 

Οποιαδήποτε επιπλέον μορφοποίηση εφαρμοστεί θα εκτιμηθεί βαθμολογικά.  

Σημείωση: Για πληροφορίες μπορείτε να ανατρέξετε στην ιστοσελίδα 

www.w3schools.com. Η χρήση οποιασδήποτε έτοιμης βιβλιοθήκης κώδικα είναι 

απαγορευτική.    

 

Η εργασία θα αναρτηθεί στο σύνδεσμο  

https://docs.google.com/forms/d/e/1FAIpQLSdKZzMk2_iWEYWNC0mY7hhHRMw

7bXpdkQSGepPWL7JeXCnJ4Q/viewform?usp=pp_url&entry.302570605=mppl 

και μπορεί να αναρτηθεί έως 20/05/2024 23:59. 

http://www.w3schools.com/
https://docs.google.com/forms/d/e/1FAIpQLSdKZzMk2_iWEYWNC0mY7hhHRMw7bXpdkQSGepPWL7JeXCnJ4Q/viewform?usp=pp_url&entry.302570605=mppl
https://docs.google.com/forms/d/e/1FAIpQLSdKZzMk2_iWEYWNC0mY7hhHRMw7bXpdkQSGepPWL7JeXCnJ4Q/viewform?usp=pp_url&entry.302570605=mppl

