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Configuration and Booting

Introduction

This lab guides you through creating a bootable system capable of booting from the SD card or the QSPI
flash memory located on the board. It also demonstrates how different bitstreams can be loaded in the PL
section after the board is booted up and the corresponding application can be executed.

Objectives

After completing this lab, you will be able to:
e Create a bootable system capable of booting from the SD card

e Create a bootable system capable of booting from the QSPI flash

e Load the bitstream stored on the SD card or in the QSPI flash memory

e Configure the PL section using the stored bitstream through the PCAP resource
e Execute the corresponding application

Procedure

This lab is separated into steps that consist of general overview statements that provide information on
the detailed instructions that follow. Follow these detailed instructions to progress through the lab.

Design Description

In this lab, you will design just the PS based embedded system consists of ARM Cortex-A9 processor
SoC. The SDIO and QSPI interfaces are included in the base design. The base design will then load the
user selected design, consisting of both different hardware and software, and execute it. The following
diagram represents the completed design (Figure 1).

Figure 1. Completed Design
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General Flow for this Lab

Step 1: Step 2: Step 3: Step 4:
Create a |:> Create the |:> Export the |:> Create the |:>
Vivado Hardware Design to the Boot Images
Project System using SDK and Test

IP Integrator

Step 5: Step 6: Step 7: Step 8:
Prepare for Create the SD Create the Test the
the Multi- Card Image |:> QSPI |:> QSPI Multi-
Applications and Test Application Applications
Boot and Image

In the instructions below;
{sources} refers to: C:\xup\adv_embedded\2017_1 zyng_sources
{labs} refers to : C:\xup\ adv_embedded \2017_1_zynq_labs

Board support for the Zybo is not included in Vivado 2017.1 by default. The relevant zip file need to be
extracted and saved to: {Vivado installation}\data\boards\board_files\.

These files can be downloaded either from the Digilent, Inc. webpage
(https://reference.digilentinc.com/vivado/boardfiles2015) or the XUP webpage
(http://www.xilinx.com/support/university/vivado/vivado-workshops/Vivado-adv-embedded-design-
zyng.html ) where this material is also hosted.

Create a Vivado Project Step 1

1-1. Launch Vivado and create an empty project, called lab5, using the Verilog
language.

1-1-1. Open Vivado and click Create New Project and click Next.

1-1-2. Click the Browse button of the Project Location field of the New Project form, browse to {labs},
and click Select.

1-1-3. Enter lab5 in the Project Name field. Make sure that the Create Project Subdirectory box is
checked. Click Next.

1-1-4. Select the RTL Project option in the Project Type form, and click Next.

1-1-5. Select Verilog as the Target Language in the Add Sources form, and click Next.
1-1-6. Click Next two times.

1-1-7. Click Boards, and select the Zybo or ZedBoard (choose your revision) and click Next.

1-1-8. Click Finish to create an empty Vivado project.
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Creating the Hardware System Using IP Integrator Step 2

2-1.

2-1-1.

2-1-2.

2-1-3.

2-1-4.

2-1-5.

2-1-6.

2-2.

2-2-1.

2-2-2.

2-2-3.

2-2-4,

2-2-5.

2-2-6.

Create a block design in the Vivado project using IP Integrator to generate
the ARM Cortex-A9 processor based hardware system.

In the Flow Navigator, click Create Block Design under IP Integrator.

Name the block system and click OK.

Click the ¥+ button.

Once the IP Catalog is open, type zy into the Search bar, and double click on ZYNQ7
Processing System entry to add it to the design.

Click on Run Block Automation in the message at the top of the Diagram panel. Leave the default
option of Apply Board Preset checked, and click OK.

Double click on the Zynq block to open the Customization window.

A block diagram of the Zyng should now be open, showing various configurable blocks of the
Processing System.

Configure the 1/0O Peripherals block to only have QSPI, UART 1, GPIO, EMIO
with 1 bit, and SD 0 support. Deselect TTC device.

Click on the MIO Configuration panel to open its configuration form.
Expand the 10 Peripherals on the right.

Uncheck ENET 0, USB 0, and USB Reset and 12C reset, leaving UART 1 and SD 0 selected.
Select EMIO and setitto 1.

In the MIO Configuration panel, expand the Application Processing Unit and uncheck the
Timer O.

Click OK.

The configuration form will close and the block diagram will be updated.

Using wiring tool, connect FCLK_CLKO to M_AXI_GPO0O_ACLK. The block diagram will look as
shown below.

pracessing_system?_0
aPioo + |||
DOR -+
M_AXI_GPO_ACLK ZYNO‘ oY )

FCLK_RESETO_N &

Gean -+
oo +|l—» ooR

DOR - FOED 0 + ||l FIXED IO

FIXED 10 e M_AX]_GPO_ACLEK é\(l\]{)

(a) ZedBoard (b) Zybo
Figure 2. ZYNQ7 Processing System configured block
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2-2-7. Select the Diagram tab, and click on the & (Validate Design) button to make sure that there are
no errors.

Export the Design to the SDK and create the software projects Step 3

3-1. Create the top-level HDL of the embedded system, and generate the
bitstream.

3-1-1. In Vivado, select the Sources tab, expand the Design Sources, right-click the system.bd and
select Create HDL Wrapper and click OK.

3-1-2. Click on Generate Bitstream and click Generate. Click Save to save the project, and Yes if
prompted to run the processes. Click OK to launch the runs.

3-1-3. When the bitstream generation process has completed successfully, click Cancel.

3-2. Export the design to the SDK and create the Hello World application.
3-2-1. Export the hardware configuration by clicking File > Export > Export Hardware...
3-2-2. Click the box to Include Bitstream, then click OK

3-2-3. Launch SDK by clicking File > Launch SDK and click OK

3-2-4. In SDK, select File > New > Application Project.

3-2-5. Enter hello_world in the project name field, and leave all other settings as default.

3-2-6. Click Next and make sure that the Hello World application template is selected, and click Finish
to generate the application.

3-2-7. Right click on hello_world_bsp and click Board Support Package Settings

3-2-8. Tick to include xilffs click OK (This is required for the next step to create the FSBL).

3-3. Create a first stage bootloader (FSBL).
3-3-1. Select File > New > Application Project.

3-3-2. Enter zynq_fsbl as the project name, select the Use existing standalone Board Support Package
option with hello_world_bsp, and click Next.
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ER New Project =y X
Application Project v ﬁ
Create a managed make application project.
Project name: zyng_fsbl
Use default location
Chwp\adv_embedded\2017_1_zyng_labs\lab5\lab5.sdk\zyng_fsb Browse
default ~
OS Platform: [standalone VI
Target Hardware
Hardware Platform: lsystem_wrapper_hw_pla‘rform_[) '] [New...l
Processor: lps?_corte)(aQ_O A l
Target Software
Language: @C ©Cc++
32-bit hd
N/A -
Board Support Package: () Create New | zyng_fsbl_bsp
@) Use existing |hello_warld_bsp S
'f?;' < Back Mext = ] [ Finish l [ Cancel

Figure 3. Creating the FSBL Application

3-3-3.

Select Zynq FSBL in the Available Templates pane and click Finish.

A zyng_fsbl project will be created which will be used in creating the BOOT.bin file. The
BOOT.hin file will be stored on the SD card which will be used to boot the board.

Create the Boot Images and Test

Step 4

4-1. Using the Windows Explorer, create a directory called image under the lab5
directory. You will create the BOOT.bin file using the FSBL,
system_wrapper.bit and hello_world.elf files.

4-1-1. Using the Windows Explorer, create a directory under the lab5 directory and call it image.

4-1-2. Inthe SDK, select Xilinx Tools > Create Boot Image.
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Click on the Browse button of the Output BIF field, browse to {labs}\lab5\image and click Save
(leaving the default name of output.bif)

4-1-3. Click on the Add button of the Boot image partitions, click the Browse button in the Add Partition
form, browse to {labs}\lab5\lab5.sdk\zynq_fsbl\Debug directory (this is where the FSBL was
created), select zynqg_fsbl.elf and click Open.

Note the partition type is bootloader, then click OK.
Add partition -
Add new boot image partition P
Add new boot image partition '@
File path:  C:\xup\adv_embedded\2017 1 _zynq_labs\lab5\lab5.sdk\zyng_fsbl\Debug\zyng_fsbl.elf
Partition type: lbootloader 'I
none 4 none 7
Checksum: lnone vl
Figure 4. Adding FSBL partition

4-1-4. Click on the Add button of the Boot image partitions and add the bitstream, system_wrapper.bit,
from {labs}\lab5\lab5.sdk\system_wrapper_hw_platform_0 and click OK.

4-1-5. Click on the Add button of the Boot image partitions and add the software application,
hello_world.elf, from {labs}\lab5\lab5.sdk\hello_world\Debug and click OK.

4-1-6. Click the Create Image button.
The BOOT.bin and the output.bif files will be created in the {labs}\lab5\image directory. We will
use the BOOT.hin for the SD card boot up.
m Create Boot Image @
Create Boot Image ?
Creates Zynq Boot Image in .bin format from given FSBL elf and partition files in specified output folder. @
Architecture:
@) Create new BIF file ) Import from existing BIF file
Basic | Security
Output BIF file path: I C\xup\adv_embedded\2017_1_zyng_labs\lab5\image\output.bif
UDF data:
[ spilit Output format:
Qutput path: C\xup\adv_embedded\2017_1_zyng_labs\lab5\image\BOOT.bin
Boot image partitions
File path Encrypted  Authentic...
(bootloader) C\xuph\adv_embedded\2017_1_zynq_labs\lab5\lab5.sdk\zyng_fsbl\Debug\zyng_fsbl.elf none none
C\xup\adv_embedded\2017_1_zynqg_labs\lab5\lab5.sdk\system_wrapper_hw_platform_0\system_wrapper.bit none none
Cihxup\adv_embedded\2017_1_zyng_labs\lab5\lab5.sdk\hello_world\Debug\hello_world.elf none none
(;7) [Preview BIF Changes] I Create Image I l Cancel I
Figure 5. Creating BOOT.bin image file
Zyng 5-6 www.xilinx.com/university v
Xup@xilinx.com i“ XI LINX“‘

© copyright 2017 Xilinx



Lab Workbook Configuration and Booting

4-1-7.

4-2.

4-2-1.

4-2-2.

4-2-3.

4-2-4.

4-2-5.

4-2-6.

4-3.

4-3-1.

4-3-2.

4-3-3.

4-3-4.

4-3-5.

4-3-6.

Insert a blank SD/MicroSD card (FAT32 formatted) in a Card reader, and using the Windows
Explorer, copy the BOOT.bin file from the image folder in to the SD/MicroSD card.

Set the board in SD card boot mode. Test the functionality by starting a
Terminal emulator program and powering ON the board.

Set the board in the SD card boot mode (For Zedboard, set the mode pins JP7-JP11 as GND-
SIG, GND-SIG, SIG-3V3, SIG-3V3, GND-SIG (right-to-left), and for Zybo set the JP5 jumper to
SD).

Insert the SD/MicroSD card into the board.
Power ON the board.

Connect your PC to the UART port with the provided micro-USB cable, and start Terminal or SDK
Terminal in SDK or a Terminal emulator program setting it to the current COM port and 115200
baud rate.

You should see the Hello World message in the terminal emulator window. If you don't see it,
then press the PS_RST/PS_SRST (Red button) button on the board.

Once satisfied power OFF the board and remove the SD card.

Set the board in the QSPI boot mode. Power ON the board, Program the
QSPI using the Flash Writer utility, and test by pressing PS-RST button.

Set the board in the QSPI mode (For Zedboard set the mode pins JP7-JP11 as GND-SIG, GND-
SIG, GND-SIG, SIG-3V3, GND-SIG ([right-to-left) and for Zybo set JP5 to QSPI).

Power ON the board.

Connect your PC to the UART port with the provided micro-USB cable, and start a Terminal
emulator program setting it to the current COM port and an 115200 baud rate.

Select Xilinx Tools > Program Flash.

In the Program Flash Memory form, click the Browse button, and browse to the
{labs}lab5\image directory, select BOOT.bin file, and click Open.

In the Offset field enter 0 as the offset and click the Program button.

The QSPI flash will be programmed.
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= =)
Program Flash Memory
Program Flash Memory via In-system Programmer. ‘
Hardware Platform: lsystem_wrapper_hw _platform_0 v‘
Connection: lLocaI v‘ l New ‘
Device: Auto Detect
Image File: Chxuphadv_embedded\2017_1_zyng_labs\lab5\image\BOOT.bin
Offset: 0
Flash Type gspi_single "
Browse
Convert ELF to bootloadable SREC format and program
["] Blank check after erase
[ verify after flash
'f?:' Program l l Cancel

Figure 6. Program Flash Memory form
4-3-7. Disconnect and reconnect the Terminal window.

4-3-8. Press the PS-RST (ZedBoard) or PS-SRST (Zybo) (Red button) button on the board to see the
Hello World message in the terminal emulator window.

4-3-9. Once satisfied, power OFF the board.

Prepare for the Multi-Applications Boot Using SD Card Step 5

Steps 5-1 and 5-2 are optional. They convert the labl and lab3 executable files to the required (.bin)
format for copying to the SD card later in step 6. The area in memory allocated for each application will be
modified so that they do not overlap each other, or with the main application. The prepared bin files
provided in the directory: {sourcesflab5\ [zybo | zedboard]\SDCard can be used for copying to the SD
card. If the two steps are skipped, proceed to 5-3.

5-1. (OPTIONAL) Start another instance of the SDK program. Open the labl
project, change the ps7_ddr_0 to 0x00200000 and the Size to Ox1FE00000
in the Iscript.ld (linker script) file. Recompile the labl.c file. Use objcopy
command to convert the elf file into the binary file and note the size of the
binary file as well as the program entry point (main()).

5-1-1. Start the SDK program and browse to the workspace pointing to {labs}\lab1\lab1.sdk\ and click
OK.
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5-1-2. Right-click on the lab1 project, select the Generate Linker Script option, change the code, data,
heap, and stack sections to use the ps7_ddr_0, and click Generate. Click Yes to overwrite the
linker script.

5-1-3. Expand the labl > src entry in the Project Explorer, and double-click on the Iscript.Id to open it.

4 [ labl
- #% Binaries
» [ Includes
> = Debug
4 (= 5rc
- g labl.c

= README.txt

Figure 7. Accessing the linker script to change the base address and the size

5-1-4. In the Iscript editor view, change the Base Address of the ps7_ddr_0_AXI_BASEADDR from
0x00100000 to 0x00200000, and the Size from Ox1FF00000 to 0x1FE00000.

MName Base Address Size
ps7_ddr_0 0x1FE00000
ps/_qspi_linear_ 0 OxFCO0O0000 Ox1000000
ps/_ram_0 Ox0 Ox30000
ps/_ram_1 OxFFFFOOO0 OxFEOQO

Figure 8. Changing the Base address and the size
5-1-5. Press Ctrl-S to save the change.

The program should compile.
5-1-6. Inthe SDK of the lab1l project, select Xilinx Tools > Launch Shell to open the shell session.
5-1-7. In the shell window, change the directory to lab1\Debug using the cd command.

5-1-8. Convert the labl.elf file to lablelf.bin file by typing the following command.

arm-none-eabi-objcopy -O binary labl.elf lablelf.bin

5-1-9. Type Is -l in the shell window and note the size of the file. In this case, it is 32776, which is
equivalent to 0x8008 bytes.

5-1-10. Determine the entry point “main()” of the program using the following command in the shell
window.

arm-none-eabi-objdump -S labl.elf | grep main

It should be in the 0x002005e4.
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5-1-11.

Make a note of these two numbers (length and entry point) as they will be used in the
lab5_sd application.

Close the Shell window.

(OPTIONAL) Switch the workspace to lab3’s SDK project. Assign all
sections to ps7_ddr_0 and generate the linker script. Change the
ps7_ddr_0 to 0x00600000 and the Size to Ox1FAQ0000 in the Iscript.ld
(linker script) file as you did in the previous step. Recompile the lab3.c file.
Use the objcopy command to convert the elf file into the binary file and
note the size of the binary file as well as the program entry point “main()”.

This step is optional. If this step is skipped, proceed to 5-3.

5-2-1. Inthe SDK program switch the workspace by selecting File > Switch Workspace > Other... and
browse to the workspace pointing to {labs}\lab3\lab3.sdk\ and click OK.

5-2-2. Right-click on the lab3 entry, select the Generate Linker Script option, change the code, data,
heap, and stack sections to use the ps7_ddr_0, and generate the linker script.

5-2-3. Expand the lab3 > src entry in the Project Explorer, and double-click on the Iscript.ld to open it.

5-2-4. In the Iscript editor view, change the Base Address of ps7_ddr_0 from 0x00100000 to
0x00600000, and the Size from 0x1FF00000 to 0x1FA00000.

5-2-5. Press Citrl-S to save the change.
The program should compile.

5-2-6. Inthe SDK of the lab3 project, select Xilinx Tools > Launch Shell to open the shell session.

5-2-7. In the shell window, change the directory to lab3\Debug using the cd command.

5-2-8. Convert the lab3.elf file to lab3elf.bin file by typing the following command.
arm-none-eabi-objcopy -O binary lab3.elf lab3elf.bin

5-2-9. Type Is - in the shell window and note the size of the file. In this case, it is 32776 again which is
equivalent to 0x8008.

5-2-10. Determine the entry point (main()) of the program using the following command in the shell
window.
arm-none-eabi-objdump -S lab3.elf | grep main
It should be in the 0x006005e4.
Make a note of these two numbers (length and entry point) as they will be used in the
lab5_sd application.
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5-2-11. Close the shell window.

5-2-12. Exit the SDK of lab3.

5-3. Create the lab5_sd application using the provided lab5_sd.c and devcfg.c,
devcgf.h, load_elf.s files.

5-3-1. Select File > New > Application Project.

5-3-2. Enter lab5_sd as the project name, click the Use existing option in the Board Support Package
(BSP) field and select hello_world_bsp, and then click Next.

5-3-3. Select Empty Application in the Available Templates pane and click Finish.

5-3-4. Selectlab5 sd > src in the project view, right-click, and select Import.

5-3-5. Expand the General folder and double-click on File system, and browse to the {sources}\lab5
directory.

5-3-6. Select devcfg.c, devcfg.h, load_elf.s, and lab5_sd.c, and click Finish.
The program won’t compile successfully indicating LAB1_BITFILE_LEN and LAB3_BITFILE_LEN
are not defined.

5-3-7. Selectlab5 sd > C/C++ Build Settings. Click on Symbols under the ARM gcc compiler group,
click the + button and enter either ZED or ZYBO depending on the board. Click OK twice.
The program should compile successfully and generate the lab5_sd.elf file.

5-3-8. Change, if necessary, LAB1_ELFBINFILE_LEN, LAB3_ELFBINFILE_LEN,
LAB1_ELF EXEC_ADDR, LAB3_ELF _EXEC_ADDR values and save the file.

Create the SD Card Image and Test Step 6
6-1. Using the Windows Explorer, create the SD_image directory under the lab5
directory. You will first need to create the bin files from lab1 and lab3.

6-1-1. Using the Windows Explorer, create directory called SD_image under the lab5 directory.
6-1-2. In Windows Explorer, copy the system_wrapper.bit of the lab1 project into the SD_image

directory and rename it lab1.bit, and do similar for lab3

{labs}/labl/labl.runs/impl_1/system_wrapper.bit -> SD_image /labl.bit
{labs}/lab3/lab3.runs/impl_1/system_wrapper.bit -> SD_image /lab3.bit

The XSDK bootgen command will be used to convert the bit files into the required binary format. bootgen
requires a .bif file which has been provided in the sources/lab5 directory. The .bif file specifies the
target .bit files.
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6-1-1. Open a command prompt by selecting Xilinx Tools > Launch Shell.

6-1-2. In the command prompt window, change the directory to the bitstreams directory.
cd {labs}/1ab5/SD_image

6-1-3. Generate the partial bitstream files in the BIN format using the provided “.bif” file located in the
sources directory. Use the following command:

bootgen -image .-\..\..\2017_1 zynqg_sources\lab5\bit_files_bif -w -
process_bitstream bin

6-1-4. Rename the files labl.bit.bin and lab3.bit.bin to lab1.bin and lab3.bin

6-1-5. The size of the file needs to match the size specified in the lab5_sd.c file. The size can be
determined by checking the file’s properties. If the sizes do not match, then make the necessary
change to the source code and save it (The values are defined as LAB1_BITFILE LEN and
LAB3_BITFILE_LEN).

C:\xup\adv_embedded\2017_1_zyng_labs\1lab5\SD_image>1ls -1
total 15808
“ru-ru-ru- 1 parimalp 0 4045568 2017-05-29 19:41 labl.bin

“ru-ru-ru- 1 parimalp 0 4045674 2017-05-29 17:46 labl.bit
“ru-ru-ru- 1 parimalp 0 4045568 2017-05-29 19:41 lab3.bin
“ru-ru-ru- 1 parimalp 0 4045674 2017-05-29 17:52 lab3.bit

Figure 9. Checking the size of the generate bin file (sizes are for Zedboard)

C:\xup\adv_embedded\2017_1_zynqg_labs\1ab5\SD_image>ls -1
total 8144
“FH-rW-ru-
“rW-ru-ru-
“rW-ru-ru-
“rW-ru-ru-

parimalp @ 2083744 2017-05-31 84:51 labl.bin
parimalp @ 2083850 2017-85-31 04:42 labl.bit
parimalp @ 2083744 2017-05-31 04:51 lab3.bin
parimalp @ 2083850 2017-85-31 04:45 lab3.bit

1
1
1
1

Figure 9. Checking the size of the generate bin file (sizes are for Zybo)

Note that the labl.bin and lab3.bin files should be the same size.

6-2. You will create the BOOT.bin file using the first stage bootloader,
system_wrapper.bit and lab5_sd.elf files.

6-2-1. Inthe SDK, select Xilinx Tools > Create Boot Image.

6-2-2. For the Output BIF file path, click on the Browse button and browse to {labs}\lab5\SD_image
directory and click Save.

6-2-3. Click on the Add button and browse to {labs}\lab5\lab5.sdk\zynqg_fsbl\debug, select
zyng_fsbl.elf, click Open, and click OK.

6-2-4. Click on the Add button of the List of partitions in the boot image field and add the bitstream file,
system_wrapper.bit, from {labs}\lab5\lab5.sdk\system_wrapper_hw_platform_0 and click
OK
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6-2-5.

6-2-6.

6-3.

6-3-1.

6-3-2.

6-3-3.

6-3-4.

6-3-5.

6-3-6.

6-3-7.

Click on the Add button of the List of partitions in the boot image field and add the software
application, lab5_sd.elf, from the {labs}\lab5\lab5.sdk\lab5 sd\Debug directory and click OK

Click the Create Image button.

The BOOT.bin file will be created in the lab5\SD_image directory.

Either copy the labxelf.bin files (two) from the sources directory or from the
individual directories (if you did the optional part in the previous step and
place them in the SD_image directory. Copy all the bin files to the SD card.
Configure the board to boot from SD card. Power ON the board. Test the
design functionality

In Windows explorer, copy the lablelf.bin and lab3elf.bin files either from the
{sources}ab5\ [zybo | zedboard]\SDCard directory or from the individual directories (if you did
the optional parts in the previous step) and place them in the SD_image directory.

{labsNabl\labl.sdk\lab1\Debug\lablelf.bin -> SD_image
{labsNlab3\lab3.sdk\lab3\Debug\lab3elf.bin -> SD_image

Insert a blank SD/MicroSD card (FAT32 formatted) in an SD Card reader, and using the Windows
Explorer, copy the two bin files, the two elfbin files, and BOOT.bin from the SD_image folder in to
the SD card.

Place the SD/MicroSD card in the board, and set the mode pins to boot the board from the SD
card (Zedboard: JP7-JP11 as GND-SIG, GND-SIG, SIG-3V3, SIG-3V3, GND-SIG([right-to-left).
Zybo set JP5 to SD). Connect your PC to the UART port with the provided micro-USB cable.

Power ON the board.

Start the terminal emulator program and follow the menu. Press the PS_RST/PS_SRST button
(Red Button) if you don’t see the menu.

When finished testing one application, either power cycle the board and verify the second
application’s functionality, or press the PS_RST/PS_SRST button (Red Button) on the board to
display the menu again.

When done, power OFF the board.
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Create the QSPI application and image Step 7

Steps 7-1 and 7-2 are optional. They bring in MULTIBOOT register related code in Labl and Lab3. They
then convert the labl and lab3 executable files to the required (.bin) format. The prepared bin files
provided in the directory: {sourcesab5\ [zybo | zedboard]\QSPI can be used for creating the MCS. If the
two steps are skipped, proceed to 7-3.

7-1. (Optional) Start a new SDK session and select labl.sdk as the workspace.
Define MULTIBOOT symbol, create Zynq_fsbl application, and change the
labl BSP reference to zynqg_fsbl_bsp. Create the image using the
zyng_fsbl.elf, system_wrapper.bit, and labl.elf files.

7-1-1. Start the SDK program and browse to the workspace pointing to {labs}\lab1\lab1.sdk\ and click
OK.

7-1-2. Right-click on the lab1 entry, select the C/C++ Build Settings option.

7-1-3. Select Symbols in the left pane under the ARM gcc compiler group, click the + button on the right,
enter MULTIBOOT in open form, click OK and click OK again.

The application will re-compile as the MULTIBOOT related code is now included.

& Tool Settings |.5" Build Steps Build Artifactl Binary Parsersl @ FError Parsers‘

4 B ARM v7 gcc assembler Defined symbols (-D) HD =

& General MULTIBOOT
4 & ARM v7 gce compiler

2 Symbols
& Warnings
Figure 10. Setting user-defined symbol

7-1-4. Select File > New > Application Project

7-1-5. Enter zynq_fsbl as the project name, select the Create New option with zynq_fsbl_bsp, and
click Next.

7-1-6. Select Zynq FSBL in the Available Templates pane and click Finish.
7-1-7. Select labl in the Project Explorer pane, right-click, and select Change Referenced BSP.

7-1-8. Inthe displayed form, select zynqg_fsbl_bsp and click OK.

The labl will be re-compiled using the zynq_fsbl_bsp.
7-1-9. Inthe SDK, select Xilinx Tools > Create Boot Image.

7-1-10. Select Create new BIF file option, click the Browse button of the BIF file path field and browse to
{labsNlab1l directory, set filename as lab1, and click Save.
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7-1-11. Add the three files, zynqg_fsbl.elf, system_wrapper.bit, and labl.elf with the correct path and order.
7-1-12. Change the output filename to lab1.bin making sure that the output directory is labl.
7-1-13. Click the Create Image button.

The lab1.bin will be created in the labl directory.

7-2. (Optional) Switch workspace to lab3.sdk directory. Define MULTIBOOT
symbol, create Zynq_fsbl application, and change the lab3 BSP reference
to zyng_fsbl_bsp. Create the image using the zyng_fsbl.elf,
system_wrapper.bit, and lab3.elf files and naming it as lab3.bin in the lab3
directory.

7-2-1. Inthe SDK program switch the workspace by selecting File > Switch Workspace > Other... and
browse to the workspace pointing to {labs}\lab3\lab3.sdk\ and click OK.

7-2-2. Right-click on the lab3 entry, select the C/C++ Build Settings option.

7-2-3. Select Symbols in the left pane under the ARM gcc compiler group, click the + button on the right,
enter MULTIBOOT in open form, click OK, and click OK again.

The application will re-compile as the MULTIBOOT related code is now included.
7-2-4. Select File > New > Application Project

7-2-5. Enter zynq_fsbl as the project name, select the Create New option with zynqg_fsbl_bsp, and
click Next.

7-2-6. Select Zynq FSBL in the Available Templates pane and click Finish.
7-2-7. Select lab3 in the Project Explorer pane, right-click, and select Change Referenced BSP.

7-2-8. In the displayed form, select zynqg_fsbl_bsp and click OK.

The lab3 will be re-compiled using the zynq_fsbl_bsp.
7-2-9. Select the lab3 application in the Project Explorer view.
7-2-10. In the SDK, select Xilinx Tools > Create Boot Image.

7-2-11. Select Create new BIF file option, click the Browse button of the BIF file path field and browse to
{labsNlab3 directory, set filename as lab3, and click Save.

7-2-12. Make sure that the three files, zynqg_fsbl.elf, system_wrapper.bit, and lab3.elf file entries are
added with the correct path. Change if necessary.

7-2-13. Change the output filename to lab3.bin making sure that the output directory is lab3.
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7-2-14. Click the Create Image button.

The lab3.bin will be created in the lab3 directory.

7-2-15. Close SDK session.

7-3. Create the lab5_qgspi application using the provided lab5_qgspi.c file.
7-3-1. Select File > New > Application Project.

7-3-2. Enter lab5_gspi as the project name, select the Use existing option for the Board Support
Package, and using the drop-down button select hello_world_bsp, and click Next.

7-3-3. Select Empty Application in the Available Templates pane and click Finish.
7-3-4. Select lab5_gspi>src in the project view, right-click, and select Import.

7-3-5. Expand General folder and double-click on File system, and browse to the {sources}\lab5
directory.

7-3-6. Select lab5 gspi.c and click Finish.

The program should compile successfully and generate the lab5_qspi.elf file.

7-4. Using the Windows Explorer, create the QSPI_image directory under the
lab5 directory. Create the lab5.mcs file using the zynq_fsbl.elf,
system_wrapper.bit, and lab5_gspi.elf files (from the lab5 project), labl.bin
(from the labl project) and lab3.bin (from the lab3 project).

7-4-1. Using the Windows Explorer, create the QSPI_image directory under the lab5 directory.

7-4-2. Inthe SDK, select Xilinx Tools > Create Boot Image.

7-4-3. Select Create new BIF file option, click the Browse button of the BIF file path field and browse to
{labsNab5\QSPI_image directory, select output.bif, and click Save.

7-4-4. Click on the Add button of the Boot image partitions window.

7-4-5. Click on the Browse button of the File Path field, browse to {labs}lab5\lab5.sdk\zynq_fsbl\Debug,
select zyng_fsbl.elf, click Open, and then click OK.

7-4-6. Click on the Add button of the Boot image partition field again and add the software application,
lab5_gspi.elf, from the {labs}lab5\lab5.sdk\lab5_qspi\Debug directory.

7-4-7. Click on the Add button again of the Boot image partition field again and add the lab1.bin, either
of created boot image of the lab1l project (in {labs}\lab1) or from the provided {sources}\lab5\zed
(or zybo)\QSPI directory. Click Open.

7-4-8. Enter 0x400000 in the Offset field and click OK.
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I B8 Add partition =X

Add new boot image partition ?
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Figure 11. Adding boot image at an offset

7-4-9. Similarly, click on the Add button again of the Boot image partition field again and add the
lab3.bin, either of the created boot image of the lab3 project (in {labs}\lab3) or from the provided
{sourcesPab5\zed (or zybo)\QSPI directory. Click Open.

7-4-10. Enter 0x800000 in the Offset field and click OK.
7-4-11. Make the window bigger (taller), if necessary, so that you can see the Output path field,

7-4-12. Change the output filename to lab5.mcs and the location to {labs)\ab5\QSPI_image (if
necessary).

7-4-13. Click the Create Image button.

The lab5.mcs file will be created in the lab5\QSPI_image directory.

7-5. Set the board in the QSPI boot mode. Power ON the board. Program the
QSPI using the Flash Writer utility.

7-5-1. Set the board in the QSPI mode. Power ON the board.

7-5-2. Select Xilinx Tools > Program Flash.

v www.xilinx.com/university Zyng 5-17
i‘ XI LINX” Xup@xilinx.com

© copyright 2017 Xilinx



Configuration and Booting Lab Workbook

7-5-3. In the Program Flash Memory form, click the Browse button, and browse to the
{labsN\ab5\QSPI_image directory, select lab5.mcs file, and click Open.

7-5-4. In the Offset field enter 0 as the offset and click the Program button.

The QSPI flash will be programmed. It may take up to 4 minutes.

Test the QSPI Multi-Applications Step 8

8-1. Connect to the serial port. Press the PS-SRST button and test the
functionality.

8-1-1. Start the terminal emulator session and press PS-SRST button to see the menu.

8-1-2. Follow the menu and test the functionality of each lab.
Press 1 to load and execute labl or 2 to load and execute lab3. After each lab is executed, the

lab5 gets loaded displaying the menu. Note that labl execution terminates when all slide switches
are ON (i.e. OxF) and lab3 execution terminates after it counts from 0 to 15.

8-1-3. Once satisfied, power OFF the board.
8-1-4. Close SDK and Vivado programs by selecting File > Exit in each program.

8-1-5. Turn OFF the power on the board.

Conclusion

This lab led you through creating the boot images which were capable of booting standalone applications
from either the SD card or the QSPI flash memory. You then created the design capable of booting
multiple applications and configurations which you developed in the previous labs.
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